Back to overview

O365 Web Add-in Login Issues on New Outlook for Windows

Jul 15 at 04:36pm EDT
Affected services
Contactmonkey Application

Resolved
Jul 15 at 04:36pm EDT

Update: July 15, 2025, 16:35 EDT
Thank you for your patience.
Our engineering team has identified and resolved the issue.
Please restart Outlook to apply the fix. If you encounter any further issues or need any additional support, we're here to help.
Again, we apologize for any inconvenience caused

Update: Jul 11, 2025, 15:57 EDT:
We have identified that the login issue affecting the ContactMonkey Add-in is specific to Outlook version 1.2025.702.500.
Our engineering team has confirmed the root cause lies within this version, and the issue has been escalated to Microsoft for resolution.
In the meantime, if you're unable to log in to the Add-in, we recommend using Outlook Web Access (OWA) as a temporary workaround:
https://outlook.office365.com/mail/
You can find additional details and ongoing updates here:
https://help.contactmonkey.com/hc/en-us/articles/37998143735053-Known-Issue-Log-in-with-[…]n-with-SSO-Connection-Error-in-New-Outlook-Desktop-Add-in
We’ll continue to monitor the situation and provide updates as they become available.
Thank you for your patience.

Update: Jul 11 2025, 2:34pm EDT:
Our Engineers continue to investigate.

If you are currently logged in to the Add-in, please refrain from logging out until the issue is resolved - you may continue using its features as intended
If you cannot log in to the Add-in, please switch to OWA (https://outlook.office365.com/mail/) until the issue is resolved.

Details can be found here:
https://help.contactmonkey.com/hc/en-us/articles/37998143735053-Known-Issue-Log-in-with-Microsoft-and-Log-in-with-SSO-Connection-Error-in-New-Outlook-Desktop-Add-in

Update: Jul 11 2025, 1:37pm EDT:
Our team has investigated reports of degraded performance and determined that the root cause is related to a known Microsoft issue impacting Outlook functionality.

We will continue to provide updates as more information becomes available.
Thank you for your patience and understanding.

JUly 11 2025, 1:23pm EDT:
Please be advised that we are seeing issues with the Microsoft Login/Connection Error with New Outlook Add-in.
Error: login.microsoftonline.com refused to connect.

To note - our Add-In for OWA & Classic Outlook are working correctly.

We've escalated the issue to our Engineering Team and we are investigating.|

Apologies for any inconvenience caused.