Back to overview
Degraded

Dashboard is unavailable

Jul 18 at 12:48pm EDT
Affected services
Contactmonkey Application

Resolved
Jul 18 at 01:13pm EDT

We have identified that the issue was caused by a service outage in our AWS region. All services are now stable & operational. Our engineering team will continue to monitor.

Updated
Jul 18 at 01:11pm EDT

We are continuing to experience dashboard loading issues in our US region. Our EU region is unaffected.

Created
Jul 18 at 12:48pm EDT

Our dashboard is currently unavailable for a percentage of our users. Our engineering team is investigating and we will provide an update shortly.