https://www.contactmonkey.com/
Status: Resolved
Impact: Degraded Performance (Partial)
Components: Web App → Email Library / Templates
This issue is resolved. Search, tag filtering, and pagination in the Emails tab are working normally again across all regions.
If you still see stale results, a single hard refresh (Cmd+Shift+R / Ctrl+Shift+R) will clear the cached page. If anything still looks off after that, contact our support team and we'll pick it up straight away.
Thank you again for your patience, and apologies fot any inconvenience caused.
Resolved
Status: Resolved
Impact: Degraded Performance (Partial)
Components: Web App → Email Library / Templates
This issue is resolved. Search, tag filtering, and pagination in the Emails tab are working normally again across all regions.
If you still see stale results, a single hard refresh (Cmd+Shift+R / Ctrl+Shift+R) will clear the cached page. If anything still looks off after that, contact our support team and we'll pick it up straight away.
Thank you again for your patience, and apologies fot any inconvenience caused.
Identified
Status: Identified
Impact: Degraded Performance (Partial) — unchanged
Components: Web App → Email Library / Templates
We've identified the cause and a fix is now deploying.
Our engineers have identified the cause of the issue and have a fix in place.
We will be deploying the fix shortly.
Thank you for your continued patience, and apologies for any inconvenience caused.
Investigating
Status: Investigating
Impact: Degraded Performance (Partial)
Components: Web App → Email Library / Templates
We're investigating an issue affecting the Emails tab in ContactMonkey. Some customers are unable to search the email library, filter templates by tag, or paginate past the first page of results.
Your emails and templates are safe. Nothing has been deleted — this is a retrieval and display issue only. Sending, tracking, and analytics are unaffected.
Workaround while we fix this: if you know the name of the email you need, opening it directly from a recent link or a Dashboard/Analytics entry will still load it normally.
https://help.contactmonkey.com/hc/en-us/articles/47674195357453-Known-Issue-Email-Library-Search-Tag-Filtering-and-Pagination-Not-Returning-Results
Our engineering team is actively investigating the root cause.