https://www.contactmonkey.com/
We are pleased to confirm that the issue affecting synced Contact Lists has been fully resolved.
Our engineering team has completed the global audit and backfill process for all affected organizations, including the final group in the US region. All contact counts are now displaying accurately.
We sincerely appreciate your patience and cooperation while we worked to resolve this.
If you notice any lingering discrepancies with your specific lists, please reach out to our Support team for immediate assistance.
Resolved
We are pleased to confirm that the issue affecting synced Contact Lists has been fully resolved.
Our engineering team has completed the global audit and backfill process for all affected organizations, including the final group in the US region. All contact counts are now displaying accurately.
We sincerely appreciate your patience and cooperation while we worked to resolve this.
If you notice any lingering discrepancies with your specific lists, please reach out to our Support team for immediate assistance.
Monitoring
We have backfilled recipient list data for all organizations that reported issues so far.
Our engineering team has run a comprehensive audit to identify any remaining accounts that require a manual data backfill.
Timeline: Due to the volume of data, a small handful of organizations in the US region are still being processed.
What You Should Do
While almost all active accounts are now restored, we still recommend clicking the "Count Recipients" button before sending a campaign to confirm your numbers are accurate.
We appreciate your continued patience as we finalize these repairs.
Identified
Our ongoing investigation has revealed that the synchronization discrepancy originally identified with Workday may also be affecting other List syncs.
While we work on a comprehensive fix, we are expanding our monitoring to include all integrated data sources to ensure data integrity across the platform.
To ensure your communications reach your entire audience, please perform the following check:
Add your Contact List
Click the "Count Recipients" button
Verify that the resulting number matches what's shown in the Directory.
If the recipient count appears incorrect or lower than expected, please use one of the following methods instead:
Please see our Help Center article for more here: https://help.contactmonkey.com/hc/en-us/articles/40715276706573-Known-Issue-Workday-Contact-Lists-Displaying-Incorrect-Recipient-Counts-and-Not-Sending-to-All-Recipients
Thank you for your continued patience.
Investigating
Our Engineers are continuing their investigation of the underlying cause of the incorrect recipient counts.
In the meantime, a workaround can be found here:
https://help.contactmonkey.com/hc/en-us/articles/40715276706573-Known-Issue-Workday-Contact-Lists-Displaying-Incorrect-Recipient-Counts-and-Not-Sending-to-All-Recipients
Investigating
Summary of Issue
We are currently investigating a technical discrepancy involving Contact Lists synced via Workday. We have identified an issue where recipient counts are not calculating correctly.
What This Means for You
If you are using a contact list integrated with Workday, the total number of recipients displayed may be inaccurate. Consequently, any campaigns sent to these specific lists will not deliver to all intended recipients.
Note: Contact lists and integrations with other providers (e.g., CSV, Azure AD, HRIS API) remain unaffected at this time.
We apologize for the interruption to your workflow.
We have escalated the issue and our engineers are currently investigating, we will provide the next update as soon as possible.
Thank you.