https://www.contactmonkey.com/
Current Status: Resolved
AWS has confirmed that the DNS resolution issues have been resolved.
Our services have returned to normal performance levels for surveys and Microsoft Teams posts.
Please note that a minor backlog may cause slight delays when creating new configurations or propagating changes to existing settings. We are monitoring the platform to ensure continued stability.
Resolved
Current Status: Resolved
AWS has confirmed that the DNS resolution issues have been resolved.
Our services have returned to normal performance levels for surveys and Microsoft Teams posts.
Please note that a minor backlog may cause slight delays when creating new configurations or propagating changes to existing settings. We are monitoring the platform to ensure continued stability.
Investigating
We are aware of an ongoing AWS DNS issue that is causing degraded performance for Surveys and Microsoft Teams across all regions.
Our team is monitoring the situation closely as the provider works toward a resolution.
AWS Status can be found here: http://status.aws.amazon.com/