Status: Resolved
Microsoft has confirmed that its affected infrastructure has returned to a healthy state and is operating as expected. Should you continue to experience any residual delays, Microsoft recommends clearing your local DNS cache to expedite the update.
Official Microsoft Status: https://admin.cloud.microsoft/?#/servicehealth/:/alerts/MO1221364
No components marked as affected
Resolved
Status: Resolved
Microsoft has confirmed that its affected infrastructure has returned to a healthy state and is operating as expected. Should you continue to experience any residual delays, Microsoft recommends clearing your local DNS cache to expedite the update.
Official Microsoft Status: https://admin.cloud.microsoft/?#/servicehealth/:/alerts/MO1221364
Monitoring
Current Status: Monitoring (Third-Party Issue)
We are aware of an ongoing Microsoft issue where users may experience delays or failures when sending and receiving emails through Outlook. This has been identified as a broad Microsoft service disruption
(Issue ID: MO1221364).
Because this is a global Microsoft service issue, our internal systems remain fully functional, but your ability to send or receive mail via Outlook may be impacted. We are monitoring Microsoft’s progress closely and will provide further updates as they resolve the incident.
Official Microsoft Status: https://admin.cloud.microsoft/?#/servicehealth/:/alerts/MO1221364
https://www.contactmonkey.com/