US Region: Log in with Microsoft in New Outlook's Add-in Only Redirects to Dashboard Homepage
Resolved·Degraded performance

Status: Resolved The issue affecting "Log in with Microsoft" for New Outlook users in the US Region is now fully resolved. After deploying a fix and monitoring the environment overnight, we have confirmed that the authentication flow has returned to normal levels.

We apologize for the inconvenience and appreciate your patience.

Wed, Jan 14, 2026, 02:16 PM
(2 weeks ago)
·
Affected components
ContactMonkey Application
Updates

Resolved

Status: Resolved The issue affecting "Log in with Microsoft" for New Outlook users in the US Region is now fully resolved. After deploying a fix and monitoring the environment overnight, we have confirmed that the authentication flow has returned to normal levels.

We apologize for the inconvenience and appreciate your patience.

Wed, Jan 14, 2026, 02:16 PM

Monitoring

Status - Monitoring: We have deployed a fix for the login redirection issue affecting US Region users in New Outlook. Initial testing indicates that the "Log in with Microsoft" flow is returning to normal.

Please attempt to log in via New Outlook and let us know if you continue to experience issues.
We will continue to closely monitor the service.

Tue, Jan 13, 2026, 10:42 PM(15 hours earlier)

Investigating

Status - Investigating: Our investigation continues into the login redirection issue affecting US Region users in New Outlook. Our engineering team is working toward a resolution, which we anticipate will be ready for deployment tomorrow morning.

Please continue using the Classic Outlook client or Outlook Web Access (OWA) as a temporary workaround while we work on a fix.
Please refer to the following help article for step-by-step guidance: https://help.contactmonkey.com/hc/en-us/articles/42650185880461-Known-Issue-Login-Issues-in-New-Outlook

Tue, Jan 13, 2026, 10:21 PM(20 minutes earlier)

Investigating

Status -  Investigating: We are investigating an issue affecting some users in the US Region attempting to log in via Microsoft in the "New Outlook" desktop application.

Affected users are being redirected to the homepage instead of completing the authentication flow.
We recommend using the Classic Outlook client or Outlook Web Access (OWA) as a temporary workaround while we work on a fix.
Please refer to the following help article for step-by-step guidance: https://help.contactmonkey.com/hc/en-us/articles/42650185880461-Known-Issue-Login-Issues-in-New-Outlook

Tue, Jan 13, 2026, 09:38 PM(42 minutes earlier)
Powered by

https://www.contactmonkey.com/