ContactMonkey Email Builder is not loading & Email Sends are slow
Resolved·Degraded performance

Resolved: The Email Builder issue has been fully resolved, and a fix has been successfully deployed. Users who were previously unable to access the Email Builder can now use it as expected.

The issue affecting Email Sends has been resolved, with a fix deployed. Please note that any emails that were previously stuck will need to be resent manually.

We appreciate your patience while our teams worked to resolve these issues.


Thu, Jan 8, 2026, 05:59 PM
(2 weeks ago)
·
Affected components
ContactMonkey Application
Updates

Resolved

Resolved: The Email Builder issue has been fully resolved, and a fix has been successfully deployed. Users who were previously unable to access the Email Builder can now use it as expected.

The issue affecting Email Sends has been resolved, with a fix deployed. Please note that any emails that were previously stuck will need to be resent manually.

We appreciate your patience while our teams worked to resolve these issues.


Thu, Jan 8, 2026, 05:59 PM

Identified

Update: Our engineering team has identified the root cause of the Email Builder initialization issue.A temporary workaround has been established for affected users to bypass the issue while we continue to work towards a full resolution. Please refer to the following help article for step-by-step guidance:
https://help.contactmonkey.com/hc/en-us/articles/42514527525517-Known-Issue-Email-Builder-Failing-to-Initialize-and-Email-Sending-Failures

Our engineers are continuing to investigate separate reports of email delivery delays and will share more information as it becomes available.

Thu, Jan 8, 2026, 04:08 PM(1 hour earlier)

Investigating

We are currently investigating two issues:
Email Builder is not loading for some users
Some Email Campaigns may appear stalled and take longer than expected to send.

Our Engineering team has been notified and is working to restore normal processing.
We will provide an update as soon as more information is available.

Thank you for your patience.

Thu, Jan 8, 2026, 03:18 PM(49 minutes earlier)
Powered by

https://www.contactmonkey.com/